name.remal.cross-gradle-versions-checks

Plugin class: name.remal.gradle_plugins.plugins.gradle_plugins.CrossGradleVersionsChecksPlugin

plugins {
    id 'name.remal.cross-gradle-versions-checks' version '1.0.178'
}
plugins {
    id("name.remal.cross-gradle-versions-checks") version "1.0.178"
}

 

Applying this plugin makes sense if you're developing a Gradle plugins

The plugin applies these plugins:

 

The main plugin's functionality is creating clones for Test tasks. Cloned tasks have replaced dependencies:

  • localGroovy to name.remal.gradle-api:local-groovy
  • gradleApi to name.remal.gradle-api:gradle-api
  • gradleTestKit to name.remal.gradle-api:gradle-test-kit
  • embeddedKotlin to name.remal.gradle-api:embedded-kotlin
  • correspondingKotlin to name.remal.gradle-api:embedded-kotlin
  • correspondingKotlinGradlePlugin to name.remal.gradle-api:corresponding-kotlin-plugin

For each Gradle version a Test task clone is created.