name.remal.groovy-settings

Plugin class: name.remal.gradle_plugins.plugins.groovy.GroovySettingsPlugin

plugins {
    id 'name.remal.groovy-settings' version '1.0.211'
}
plugins {
    id("name.remal.groovy-settings") version "1.0.211"
}

 

This plugin works only if groovy plugin is applied.

The plugin applies name.remal.java-settings plugin.

 

This plugin helps to configure groovy plugin.

  • Puts Kotlin compiled classes in classpath of GroovyCompile tasks.
  • Sets sources default encoding to UTF-8.
  • Enables displaying deprecation warnings.
  • Add --parameters compiler option if Groovy version 2.5 and above targetting Java 8 and above. (Gradle still doesn't support it: gradle/gradle#2487)